Saturday, July 21, 2007

Mencoder, x264, AAC & MP4Box binaries for PPC & Intel are Repacked

Hello...everyone....
Mencoder, x264, AAC & MP4Box binaries for PPC & Intel are repacked.
Please download the newer one and install the including package, re-assign the proper path in the preferences of PEnGUIn(x264+AAC).
By the way, video files with audio track in windows audio media 9 format may not be able to operate correctly in AAC encoding.
Thanks!!


La'fear

16 comments:

Zeta said...

No problem at all with this version :D

Thanks a lot.

La'fear said...

Thanks, Zeta.
It's my pleasure.

Gardo said...

Hello, I have a PPC Mac, and when I press launch I get this error:

Cannot find file /Volumes/LACIE/Simpsons 06x01_vid.264
Error importing /Volumes/LACIE/Simpsons 06x01_vid.264: Requested URL is not valid or cannot be found

It also happens with muxer mode in NONE. BTW I cant select PMP_MOD.

Thanx for your help

La'fear said...

Hello..Gardo...
If you would like to encode pmp video, you have to download (1) PEnGUIn Encoder 1.57u and (2) Mencoder, Mplayer, X264 & LAME Binaries for PPC Only (03.26.2007 Build).
As to (1) PEnGUIn(x264+AAC)_0.6a + Mencoder, x264, AAC & MP4Box binaries for PPC (July 21, 2007 repack) or (2) PEnGUIn(x264+AAC)_0.6a + Mencoder, x264, AAC & MP4Box binaries for Intel (July 21, 2007 repack), they are only used to encode mp4 video.
Thanks!!

Gardo said...

[quote=La'fear]
As to (1) PEnGUIn(x264+AAC)_0.6a + Mencoder, x264, AAC & MP4Box binaries for PPC (July 21, 2007 repack) or (2) PEnGUIn(x264+AAC)_0.6a + Mencoder, x264, AAC & MP4Box binaries for Intel (July 21, 2007 repack), they are only used to encode mp4 video.[/quote]


Thats what I'm trying to do (encode mp4), I just said the thing about the PMP_MOD to ask about it. Anyway, I've downloaded both of the files you're tellling me from the beginning, and I get that error.
Thanx again for your help

La'fear said...

Hello...Gardo
Would you please remove "/Volumes/LACIE/Simpsons 06x01_vid.264" first.
And then select the "H264 Encode Options" only.
Select NONE in the Muxer mode.
Press Lauch Button and copy the error messages for me.
By the way, you can also download the Extra Codes first.
Thanks a lot!!

Gardo said...

I get:

dyld: Library not loaded: /usr/local/lib/libfaac.0.dylib
Referenced from: /Applications/PEnGUIn(x264+AAC)_06a/mencoder
Reason: no suitable image found. Did find:
/usr/local/lib/libfaac.0.dylib: mach-o, but wrong architecture
/usr/local/lib/libfaac.0.dylib: mach-o, but wrong architecture

BTW the extra codes you're saying are those in this link ? http://www.mplayerhq.hu/MPlayer/releases/codecs/essential-macosx-x86-20060611.zip
I've installed them, even though they said to be for Intel.

Thanx a lot! :)

La'fear said...

Hello...Gardo...
It's my fault.
I didn't mention it before.
Inside the "Mencoder, x264, AAC & MP4Box binaries for PPC (July 21, 2007 repack)", there is a package "BINARY072007.mpkg".
You have to install it before running encoding tasks.
If you have install intel version earlier than PPC, you might need to remove "/usr/local/lib/libfaac.0.dylib" manually by Terminal.app.
And then install PPC version.
Thanks!!

Gardo said...

Hello again,

I removed "/usr/local/lib/libfaac.0.dylib" and reinstalled the "BINARY072007.mpkg" but I still get the same error.

Now when y press launch with the "H264 Encode Options" only.
and NONE in the Muxer mode i get:

dyld: Library not loaded: /opt/local/lib/libjpeg.62.dylib
Referenced from: /Applications/07092007_PPC/mencoder
Reason: image not found

Thanx again for your help ;)

La'fear said...

Hello...Gardo.....
Thanks you so much!!
Please try the newer one
"DOWNLOAD: Mencoder, x264, AAC & MP4Box binaries for PPC (Aug 21, 2007 repack)"
It will replace and add some binaries and libs.

Gardo said...

Hi La'fear , Im sorry for not replying before, but I'm not home, so I dont have my MAC with me, but I'll post results as soon as I have them

Cheers!

andersonlich said...

i've got error on '/opt/local/lib/libmp4v2.0.dylib'.

any solution bout this?

La'fear said...

Hello...Andersonlich....
Did you download the latest 0.97b2??
Please use the latest 0.97b2 and remember to update the binary under the help menu.
Thanks a lot!!

Thomas said...

Download link for mp4box powerpc binary has disappeared. Can you please reupload it?

La'fear said...

Hi, there. I have put the download link up.

Chris said...

I have your MP4Box of 0.4.5 and it seems to partially work. Figured maybe i might be missing something as something I know that should work, doesn't seem to work with this command line version:

imac:Downloads chris$ ./MP4Box -add Couples\ Retreat\ 2009\ BRRip\ H264\ AAC-SecretMyth\ \(Kingdom-Release\)/Couples\ Retreat.mp4#1:fps=23.976 -add Couples\ Retreat\ 2009\ BRRip\ H264\ AAC-SecretMyth\ \(Kingdom-Release\)/Audio\ 2\ ch/Couples\ Retreat\ audio\ track\ 2\ ch.mp4#101 File.mp4
Unknown input file type
Unknown input file type
IsoMedia import - track ID 101 - Audio (SR 48000 - 2 channels)
Converting to ISMA Audio-Video MP4 file...
Saving to File.mp4: 0.500 secs Interleaving
imac:Downloads chris$ ls -lh File.mp4
-rw-r--r-- 1 chris staff 106M Feb 5 14:17 File.mp4


But running from windows on the same file works fine:

[11:04:03] : Command Line used for Creation : "C:\Users\Chris\AppData\Roaming\Yamb\MP4Box.exe" -add "Z:\chris\Downloads\Couples Retreat 2009 BRRip H264 AAC-SecretMyth (Kingdom-Release)\Couples Retreat.mp4#1:fps=23.976" -add "Z:\chris\Downloads\Couples Retreat 2009 BRRip H264 AAC-SecretMyth (Kingdom-Release)\Audio 2 ch\Couples Retreat audio track 2 ch.mp4#101" "Z:\chris\Downloads\Couples Retreat 2009 BRRip H264 AAC-SecretMyth (Kingdom-Release)\Couples Retreat 2ch.mp4"
[11:04:03] : File saved in Z:\chris\Downloads\Couples Retreat 2009 BRRip H264 AAC-SecretMyth (Kingdom-Release)\
[11:04:04] : Importing ISO File...
[11:06:20] : Importing ISO File...
[11:06:28] : File Writing...
[11:07:27] : Creation complete.


Can anyone explain to me why it doesn't appear to like the video file using the mac mp4box?