Tuesday, July 17, 2007

PEnGUIn(x246+AAC) 0.5a Updated

Hello...
The latest 0.5a version.
Scale Options, FPS control, mode selections(ipod, AppleTV, PSP) are added.
In fact, all of these three modes, I only tested psp mode with OE firmware on PSP.
Just put the mp4 into ms:/VIDEO/.
Because I don't have ipod Video and AppleTV, the other two modes may not work appropriately.


DOWNLOAD: PEnGUIn(x264+AAC)_0.5a

4 comments:

Anonymous said...

Thank you very much but I can´t complete the process. I just got an error saying a video file (.264) but no mp4 nor audio file. The video plays correctly anyway (without sound, of course).

Here is the log:

"Import results: 39496 samples - Slices: 376 I 39120 P 0 B - 39837 SEI - 341 IDR
Opening file /Users/Richie/Desktop/Blood Episodio 17_aud.aac failed
Error importing /Users/Richie/Desktop/Blood Episodio 17_aud.aac: Requested URL is not valid or cannot be found"

La'fear said...

Hello...
Thanks for your comment.
Would you please remove Blood Episodio 17_aud.aac & Blood Episodio 17.mp4.
And then select the AAC Encoder Options only.
Select NONE in the Muxer mode.
Press Lauch Button and copy the error messages for me.
By the way, you can also download the Extra Codes first.
The download link which you can find from the help menu of PEnGUIn(x264+AAC).
Thanks a lot!!

Zeta said...

Thanks for your answer. I'll try to reproduce the process and describe it to you. I hope you'll be able to understand it cause my english is not as good as I wish :_(

-I've already downloaded and installed the extra codes from your link.

-I choose the Mencoder and MP4Box in the preferences (the last you posted, intel version cause I have a Core2Duo iMac 24").

-I add a video to queue (all videos behaves the same way).

-I mark H246 Encode and AAC encode.

-I mark PSP.

-I press Launch and choose a destination folder (desktop).

A window opens inmediatly saying:

"Encoding Tasks Have been Completed.

Tips:
There Might be Some Encoding Tasks Skipped When Output Files are Existed."

BUT no file was created. After closing the window, in the main application appears:

"Cannot find file /Users/Richie/Desktop/Blood Episodio 19_vid.264
Error importing /Users/Richie/Desktop/Blood Episodio 19_vid.264: Requested URL is not valid or cannot be found"

It seems that it's trying to open the coded video to multiplex it but there's no video cause it hadn't coded before.

In the other hand if I choose a previous version of mencoder (the one I use to create PMP files) and repeat the process with the same options then the video is coded and a file with extension .264 is created in the destination folder but no sound processing is done and the program finish with the same popup window as before and this log:

"AVC-H264 import - frame size 544 x 416 at 29.970 FPS
Importing AVC-H264: | | (01/100)
Importing AVC-H264: | | (02/100)
Importing AVC-H264: | | (03/100)

.....

.....
mporting AVC-H264: |=================== | (99/100)

Importing AVC-H264: |=================== | (99/100)

Import results: 36686 samples - Slices: 317 I 15222 P 21147 B - 36982 SEI - 296 IDR
Opening file /Users/Richie/Desktop/Blood Episodio 19_aud.aac failed
Error importing /Users/Richie/Desktop/Blood Episodio 19_aud.aac: Requested URL is not valid or cannot be found"

When I do what you wrote in the previous message I get the following report:

"MEncoder dev-SVN-rUNKNOWN-4.0.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

MPlayer was compiled without libfaac. See README or DOCS.
MPlayer was compiled without libfaac. See README or DOCS."

I hope this can help to the development of your great application.

Greetings from sunny Spain. 8)

La'fear said...

Hello...Zeta...
Thanks of your detail information.
According to your comment, I repacked the Mencoder, x264, AAC & MP4Box binaries for PPC & Intel. Please downlaod the newer one. And re-assign the proper path in the preferences.Besides, PEnGUIn(x264+AAC) 0.6a is also updated. Please try the newer one, too. By the way, if your video files with audio track in windows audio media 9, the AAC encoding may not be able to operate properly.
If there is any problem, just left the comment.
Thanks.
La'fear